Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1036590] [Build 20170425] openQA test fails in firewall_enabled
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 12 May 2017 15:10:53 +0000
  • Message-id: <bug-1036590-21960-3a46ufo4CO@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1036590
http://bugzilla.suse.com/show_bug.cgi?id=1036590#c5

Ladislav Slezák <lslezak@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Flags|needinfo?(lslezak@xxxxxxxx) |

--- Comment #5 from Ladislav Slezák <lslezak@xxxxxxxx> ---
I grepped the YaST logs from https://openqa.opensuse.org/tests/393541#downloads
and the only firewall relevant part was:

clients/firewall_stage1_finish.rb:54 starting firewall_stage1_finish

and

clients/inst_finish.rb:547 Called YaST client returned: $["steps":1,
"title":"Writing Firewall Configuration...", "when":[`installation, `autoinst]]

That refers to
https://github.com/yast/yast-network/blob/3b88346d59050a4ae2b697d3bd6dec5167010473/src/clients/firewall_stage1_finish.rb#L66:

"when" => [:installation, :autoinst]

That means the firewall is configured only in the initial installation (manual
or AutoYaST), during upgrade that's skipped.

And that's correct IMHO, during upgrade YaST should keep the previous status
and do not touch the service. If it was disabled by user is should stay
disabled.

Interestingly update from e.g. 13.2 works:
https://openqa.opensuse.org/tests/403280 (updating to the same TW)

So I guess there is some issue with the packages or the %post scripts.

BTW does it still make sense test upgrade from 12.2 when it is unsupported for
several years?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >