Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1037206] 'Unrecognized option --no-nvram' during installation of mokutil package
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 10 May 2017 04:54:16 +0000
  • Message-id: <bug-1037206-21960-z7Dh8tAjDo@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1037206
http://bugzilla.suse.com/show_bug.cgi?id=1037206#c6

Michael Chang <mchang@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |gmoro@xxxxxxxx
Flags|needinfo?(mchang@xxxxxxxx) |needinfo?(gmoro@xxxxxxxx)

--- Comment #6 from Michael Chang <mchang@xxxxxxxx> ---
(In reply to Michal Nowak from comment #5)
(In reply to Gary Ching-Pang Lin from comment #4)

Michael Chang: Perhaps you can help with explaining, why we have "GRUB for
EFI" on JeOS KVM image despite VM may not have UEFI?

Not really .. But my speculation is kiwi first boot scripts did not setup
/etc/sysconfig/bootloader correctly wrt firmware type being booted.

If you use guestfish to inspect the qcow2 image


https://openqa.opensuse.org/tests/396373/asset/hdd/openSUSE-Leap-42.3-JeOS-for-kvm-and-xen.x86_64-1.1.1-Build11.33.qcow2

The /etc/sysconfig/bootloader is initially an empty file poised to be written.
After the first boot, /etc/sysconfig/bootloader is filled with content below,
which looks wrong as its being booted on legacy bios.

LOADER_TYPE="grub2-efi"
LOADER_LOCATION="mbr"
DEFAULT_APPEND=" root=/dev/disk/by-label/ROOT disk=/dev/sda resume=swap
systemd.show_status=0 plymouth.enable=0 quiet"
FAILSAFE_APPEND="ide=nodma apm=off noresume edd=off powersaved=off nohz=off
highres=off processsor.max+cstate=1 nomodeset x11failsafe
root=/dev/disk/by-label/ROOT disk=/dev/sda resume=swap systemd.show_status=0
plymouth.enable=0 quiet"

@Guilherme,

What do you think ?

Thanks,
Michael

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References