Mailinglist Archive: opensuse-bugs (4283 mails)

< Previous Next >
[Bug 1037845] New: last python update gives anerror in games PySolFC
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 05 May 2017 18:55:44 +0000
  • Message-id: <bug-1037845-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1037845


Bug ID: 1037845
Summary: last python update gives anerror in games PySolFC
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: HP
OS: SUSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: conde.philippe@xxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101
Firefox/49.0 SeaMonkey/2.46 Lightning/5.1b1
Build Identifier:

After installing last tumbleweed snapshot (20170503) I receive an error when
loading PySolFC

pysol.py
Traceback (most recent call last):
File "/usr/bin/pysol.py", line 29, in <module>
from pysollib.main import main
File "/usr/lib/python2.7/site-packages/pysollib/main.py", line 31, in
<module>
from util import DataLoader
File "/usr/lib/python2.7/site-packages/pysollib/util.py", line 53, in
<module>
from mfxutil import Image
File "/usr/lib/python2.7/site-packages/pysollib/mfxutil.py", line 44, in
<module>
import Image
File "/usr/lib64/python2.7/site-packages/PIL/Image.py", line 27, in <module>
from . import VERSION, PILLOW_VERSION, _plugins
ValueError: Attempted relative import in non-package


This error ocuured with an old version but I reinstalled the last PySolFC from
http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/
and the same error occurs on load

Reproducible: Always

Steps to Reproduce:
1.install PySolFC from
http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/
2.load it via pysol.py
3.error is displayed
Actual Results:
pysol is not loaded

Expected Results:
Pysol should start

I removed the ~/.PySolFC library but the same error occurs after remove

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups