Mailinglist Archive: opensuse-bugs (4283 mails)

< Previous Next >
[Bug 1037511] New: Cannot use CONFIG_STACK_VALIDATION: virtualbox-host-source should require libelf-devel
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 04 May 2017 05:24:12 +0000
  • Message-id: <bug-1037511-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1037511


Bug ID: 1037511
Summary: Cannot use CONFIG_STACK_VALIDATION:
virtualbox-host-source should require libelf-devel
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Virtualization:Other
Assignee: virt-bugs@xxxxxxx
Reporter: mnowak@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

# cd /usr/src/kernel-modules/virtualbox ; make ; make install
=== Building 'vboxdrv' module ===
make[1]: Entering directory '/usr/src/kernel-modules/virtualbox/vboxdrv'
make KBUILD_VERBOSE= SUBDIRS=/usr/src/kernel-modules/virtualbox/vboxdrv
SRCROOT=/usr/src/kernel-modules/virtualbox/vboxdrv CONFIG_MODULE_SIG= -C
/lib/modules/4.11.0-1.g1b516a5-default/build -j8 modules
make[2]: Entering directory
'/usr/src/linux-4.11.0-1.g1b516a5-obj/x86_64/default'
/usr/src/linux-4.11.0-1.g1b516a5/Makefile:929: "Cannot use
CONFIG_STACK_VALIDATION, please install libelf-dev, libelf-devel or
elfutils-libelf-devel"
CC [M] /usr/src/kernel-modules/virtualbox/vboxdrv/linux/SUPDrv-linux.o
...

With VirtualBox from OBS Virtualization project on Leap 42.2. Happens with 4.11
and 4.10.x kernel sources. Warning disappears when libelf-devel is installed.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >