Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1037255] New: VUL-1: CVE-2017-8419: lame: denial of service (stack-based buffer overflow or heap-based buffer overflow) via a crafted file
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 02 May 2017 16:38:18 +0000
  • Message-id: <bug-1037255-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1037255


Bug ID: 1037255
Summary: VUL-1: CVE-2017-8419: lame: denial of service
(stack-based buffer overflow or heap-based buffer
overflow) via a crafted file
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Security
Assignee: security-team@xxxxxxx
Reporter: mikhail.kasimov@xxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

Created attachment 723519
--> http://bugzilla.opensuse.org/attachment.cgi?id=723519&action=edit
CVE-2017-8419_reproducer

Ref: https://nvd.nist.gov/vuln/detail/CVE-2017-8419
====================================================
Description

LAME through 3.99.5 relies on the signed integer data type for values in a WAV
or AIFF header, which allows remote attackers to cause a denial of service
(stack-based buffer overflow or heap-based buffer overflow) or possibly have
unspecified other impact via a crafted file, as demonstrated by mishandling of
num_channels.
====================================================

Hyperlink

[1] https://sourceforge.net/p/lame/bugs/458/

[2] Reproducer:
https://sourceforge.net/p/lame/bugs/458/attachment/lame_stack_corruption_poc.wav


(open-)SUSE: https://software.opensuse.org/package/lame

3.99.5 (TW, 42.{1,2}, hardware:sdr repo, multimedia:libs repo, and
multimedia:musescore2 repo for TW only)

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >