Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1037052] New: VUL-0: CVE-2017-8392: binutils: libbfd: objdump segfault - null pointer dereferencing (_bfd_dwarf2_find_nearest_line function)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 01 May 2017 21:58:10 +0000
  • Message-id: <bug-1037052-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1037052


Bug ID: 1037052
Summary: VUL-0: CVE-2017-8392: binutils: libbfd: objdump
segfault - null pointer dereferencing
(_bfd_dwarf2_find_nearest_line function)
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Security
Assignee: security-team@xxxxxxx
Reporter: mikhail.kasimov@xxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

Ref: https://nvd.nist.gov/vuln/detail/CVE-2017-8392
====================================================
Description

The Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU
Binutils 2.28, is vulnerable to an invalid read of size 8 because of missing a
check to determine whether symbols are NULL in the
_bfd_dwarf2_find_nearest_line function. This vulnerability causes programs that
conduct an analysis of binary programs using the libbfd library, such as
objdump, to crash.

Source: MITRE Last Modified: 05/01/2017
====================================================

Hyperlink

[1] https://sourceware.org/bugzilla/show_bug.cgi?id=21409

[2]
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=97e83a100aa8250be783304bfe0429761c6e6b6b
(see https://sourceware.org/bugzilla/show_bug.cgi?id=21409#c2)


(open-)SUSE: https://software.opensuse.org/package/binutils

2.28 (TW, official repo)
2.26.1 (42.{1,2}, official repo)

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >