Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 984778] add option to zypper up to recognize reboot_needed,relogin_needed,zypp_restart_needed flags in update info, like "zypper patch"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 01 May 2017 06:46:27 +0000
  • Message-id: <bug-984778-21960-xtcTMsBJBX@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=984778
http://bugzilla.opensuse.org/show_bug.cgi?id=984778#c11

Tony Mechelynck <antoine.mechelynck@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |ma@xxxxxxxx
Flags| |needinfo?(ma@xxxxxxxx)

--- Comment #11 from Tony Mechelynck <antoine.mechelynck@xxxxxxxxx> ---
Wouldn't it be enough to change the "default type" for the zypper lu and up
commands to both "package" and "patch"? That way, "zypper lu" would show any
needed restarts or reboots, and "zypper up" would warn about them at
end-of-run, the way they already do when explicitly started with "-t package -t
patch" on the command-line.

This would be a change in behaviour, but I don't think it would break anything.
Of course the manpage would have to be modified to mention the new behaviour,
and to mention that this new behaviour applies "starting with zypper version
x.xx".

Any user wanting either to bypass package updates without patches (e.g. those
of Packman) or OTOH to suppress reboot or restart warning messages (I don't
think there would be many such users, but who knows?) could override this new
default with an explicit -t argument.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >