Mailinglist Archive: opensuse-bugs (4258 mails)

< Previous Next >
[Bug 1004579] wired network interface not able to connect automatically (jme driver issue)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 30 Jan 2017 18:05:39 +0000
  • Message-id: <bug-1004579-21960-lYSqgnNKBg@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1004579
http://bugzilla.suse.com/show_bug.cgi?id=1004579#c6

Benjamin Poirier <bpoirier@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Flags|needinfo?(bpoirier@xxxxxxxx |
|) |

--- Comment #6 from Benjamin Poirier <bpoirier@xxxxxxxx> ---
(In reply to Søren Tarp from comment #3)
With 42.1 and older, the network interface worked fine.
Now, with Tumbleweed, I have to manually issue a command that restricts the
duplex speed of the NIC:

Are you sure that it worked with the in-tree driver in 42.1?

The only functional changes to the driver in between these two kernel versions
are related to suspend/resume:
ben@f1:~/local/src/kernel$ git log --oneline
public/openSUSE-42.1..public/stable -- drivers/net/e
thernet/jme.*
ea01964 drivers/net/ethernet/jme.c: Deinline jme_reset_mac_processor, save 2816
bytes
81422e6 jme: Fix device PM wakeup API usage
0772a99 jme: Do not enable NIC WoL functions on S0
ee50c13 net: jme: fix suspend/resume on JMC260
a188222 net: Rename NETIF_F_ALL_CSUM to NETIF_F_CSUM_MASK
e9b5ac2 net: jme: use kzalloc() instead of kmalloc+memset


Other post suggests that all this i due to a bug in the jme driver.

Actually, it seems to be a hardware problem that is worked around in software
by the out of tree driver:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/880316/comments/41
It appears that it periodically checks for link failure after
autonegotiation and then automatically tries renegotiating with only
lower speed(s) enabled.

So this is faulty hardware that can't maintain a 1000BASE-T link with
some link partners. But since it works with others, disabling
1000BASE-T operation completely would cause a regression for some
users.

I've prepared a kmp with this patch. It's available in the following
repository:
http://download.opensuse.org/repositories/home:/benjamin_poirier:/bsc1004579/openSUSE_Tumbleweed/

Please double check about 42.1 and try the kmp.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >