Mailinglist Archive: opensuse-bugs (4258 mails)

< Previous Next >
[Bug 953017] hugin won't start on Tumbleweed due do C++ ABI version mismatch
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 30 Jan 2017 12:42:05 +0000
  • Message-id: <bug-953017-21960-l7zoHXrROX@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=953017
http://bugzilla.opensuse.org/show_bug.cgi?id=953017#c3

Christian Boltz <suse-beta@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |REOPENED
CC| |suse-beta@xxxxxxxxx
Resolution|FIXED |---
Assignee|bnc-team-screening@xxxxxxxx |sbrabec@xxxxxxxx
|ovo.novell.com |

--- Comment #3 from Christian Boltz <suse-beta@xxxxxxxxx> ---
This bug is back in current tumbleweed:

# hugin
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1002,STL
containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,STL
containers,compatible with 2.8).
Aborted (core dumped)


My guess is that the latest change in wxWidgets-3_0 (which added a patch, but
didn't change the version) caused this.

I'd guess triggering a rebuild is needed once more.

It would also make sense to tighten the dependencies (down to the build
counter?) to enforce automatic rebuilds.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >