Mailinglist Archive: opensuse-bugs (4233 mails)

< Previous Next >
[Bug 1020327] [Build 20170116] openQA test fails in consoletest_finish
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 19 Jan 2017 15:10:36 +0000
  • Message-id: <bug-1020327-21960-xE2kBEOwM5@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1020327
http://bugzilla.opensuse.org/show_bug.cgi?id=1020327#c15

--- Comment #15 from Franck Bui <fbui@xxxxxxxx> ---
(In reply to Fabian Vogt from comment #14)
(In reply to Franck Bui from comment #7)
Ok, here's my best bet:

Since systemd v232, systemd-vconsole-setup.service has no more the
RemainAfterExit=true property.

Confirmed. After changing that back it works fine.
This proves that systemd-vconsole-setup configures consoles more than once,
doesn't it?


Indeed.

But it seems that the second time systemd-vconsole-setup.service is started is
not well defined and can happen after plymouthd started using the VT. And this
confuses plymouthd somehow.

OTOH I'm wondering if 90-vconsole.rules is not enough for initializing the
console, IOW if there are any wrong side effects to drop
systemd-vconsole-setup.service from initrd...

- include in the initramfs /usr/lib/udev/rules.d/90-vconsole.rules
This seems to be enough for running vconsole-setup on tty7 when
plymouth activates (or switches to) it but before it actually
uses it, so no crash happens in this case.

This is already in the initrd.

Weird it was not present on one of the system I used for my testing purposes.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References