Mailinglist Archive: opensuse-bugs (4233 mails)

< Previous Next >
[Bug 1020356] New: Active flag of UEFI boot item removed after reboot
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 17 Jan 2017 13:13:01 +0000
  • Message-id: <bug-1020356-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1020356


Bug ID: 1020356
Summary: Active flag of UEFI boot item removed after reboot
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: x86-64
OS: openSUSE 42.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
Assignee: yast2-maintainers@xxxxxxx
Reporter: mse00000@xxxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

I have an Acer Veriton M4640G with pre-installed Windows 7 in UEFI mode and
openSUSE 13.2 32 bit installed in BIOS-legacy mode because installation DVD was
not bootable in UEFI mode. "Secure Boot" is disabled in BIOS.

I installed in UEFI mode Leap 42.2, rebooting with inserted Leap DVD-> Boot
from Hard Disk shows "error: no such device: /efi/boot/fallback.efi".
Rebooting without DVD starts Windows 7.

Leap can be started by DVD->"Boot Linux System". I installed boot loader again
by Yast. "efibootmgr -v" shows
"
BootCurrent: 000C
Timeout: 1 seconds
BootOrder: 0001,000C,0009,0000,000A,000B
Boot0000* Windows Boot Manager
HD(1,800,32000,5f1880c6-3bf4-4c93-816a-6aedbaf318e0)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...c................
Boot0001* opensuse
HD(1,800,32000,5f1880c6-3bf4-4c93-816a-6aedbaf318e0)File(\EFI\opensuse\grubx64.efi)
Boot0009* HL-DT-ST DVDRAM GHD0N BIOS(3,0,00)..BO
Boot000A* ST1000DX001-1NS162 BIOS(2,0,00)..BO
Boot000B* WDC WD10EFRX-68FYTN0 BIOS(2,0,00)..BO
Boot000C* UEFI: HL-DT-ST DVDRAM GHD0N
ACPI(a0341d0,0)PCI(17,0)03120a000500ffff0000CD-ROM(1,3fd,20a448)..BO
"
Boot0001 is active.

After a restart by DVD->"Boot Linux System" "efibootmgr -v" shows
"
BootCurrent: 000C
Timeout: 1 seconds
BootOrder: 000C,0009,0000,000A,000B,0001
Boot0000* Windows Boot Manager
HD(1,800,32000,5f1880c6-3bf4-4c93-816a-6aedbaf318e0)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...c................
Boot0001 opensuse Vendor(99e275e7-75a0-4b37-a2e6-c5385e6c00cb,)
Boot0009* HL-DT-ST DVDRAM GHD0N BIOS(3,0,00)..BO
Boot000A* ST1000DX001-1NS162 BIOS(2,0,00)..BO
Boot000B* WDC WD10EFRX-68FYTN0 BIOS(2,0,00)..BO
Boot000C* UEFI: HL-DT-ST DVDRAM GHD0N
ACPI(a0341d0,0)PCI(17,0)03120a000500ffff0000CD-ROM(1,3fd,20a448)..BO
"
Boot0001 is inactive and the old boot order is in place.

"parted /dev/sda print" shows:
"
Model: ATA ST1000DX001-1NS1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name
Flags
1 1049kB 106MB 105MB fat32 EFI system partition
boot, legacy_boot
2 106MB 123MB 16.8MB Microsoft reserved partition
msftres
3 123MB 161GB 161GB ntfs Basic data partition
11 161GB 204GB 43.0GB btrfs primary
12 204GB 480GB 276GB xfs primary
4 480GB 480GB 524MB ntfs Basic data partition
hidden, diag
5 480GB 643GB 163GB ntfs Basic data partition
7 643GB 643GB 8389kB primary
bios_grub
8 643GB 645GB 2156MB linux-swap(v1) primary
9 645GB 745GB 99.9GB ext4 primary
boot, legacy_boot
10 745GB 960GB 215GB ext4 primary
6 960GB 1000GB 40.4GB ntfs Basic data partition
hidden, diag
"
(9) is openSUSE 13.2 /,(11) Leap 42.2 /, (12) Leap 42.2 /home
The installation of openSUSE 13.2 32 bit probably set the MBR.

A thread about the issue is here:
https://forums.opensuse.org/showthread.php/522318-grub-no-such-device-efi-boot-fallback-efi

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >