Mailinglist Archive: opensuse-bugs (4247 mails)

< Previous Next >
[Bug 1019886] New: Upgrade from 42.1 to 42.2 fails to initialize LVM VG with use_lvmetad = 1
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 13 Jan 2017 15:19:39 +0000
  • Message-id: <bug-1019886-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1019886


Bug ID: 1019886
Summary: Upgrade from 42.1 to 42.2 fails to initialize LVM VG
with use_lvmetad = 1
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: x86-64
OS: openSUSE 42.1
Status: NEW
Severity: Major
Priority: P5 - None
Component: Upgrade Problems
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: youri@xxxxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

When performing upgrade from 42.1 to 42.2 the system fails to initialize the
Volume Groups with default configuration.

Upgrade procedure:
===================
1) upgrade to latest patchset 42.1
2) sed -i 's/42.1/42.2/g' /etc/zypper/repos.d/*.repo
3) zypper ref && zypper dup

Issue after upgrade:
=====================
Volume Groups are not initialized and the system fails to boot if any LV's are
used in /etc/fstab.

Workarounds:
==============
Option 1) Edit /etc/lvm/lvm.conf and change "use_lvmetad = 1" to "use_lvmetad =
0"
Option 2) Add file "/etc/dracut.conf.d/20-lvm.conf" with content :
add_dracutmodules+="lvm" and run dracut --force to regenerate initrd with LVM
modules.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >