Mailinglist Archive: opensuse-bugs (4250 mails)

< Previous Next >
[Bug 1018741] after Xen 4.7 -> 4.8 upgrade, Xen PVHVM/UEFI guests fail to boot; hang @~ OVMF
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 12 Jan 2017 07:37:43 +0000
  • Message-id: <bug-1018741-21960-lSTXhuKALG@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1018741
http://bugzilla.opensuse.org/show_bug.cgi?id=1018741#c37

--- Comment #37 from lists dev <lists@xxxxxxxxxxxx> ---
(In reply to Gary Ching-Pang Lin from comment #36)
However, with bios_path_override, the Secure Boot issue can be worked around.

Yes, can boot with SecureBoot DISabled.

2) The system failed at initrd.
Per comment#16, the system dropped into the dracut emergency shell. Does
Leap 42.2 DVD work? Just wonder whether there is anything missing in initrd.

Launching it as a Guest?

I'll have to give that a try.

3) Customized grub2
Per comment#24, a customized grub2 was created. In this case,
"ovmf-x86_64-ms.bin" should not be used since the new grub.efi cannot be
verified by shim.efi.

A standalone grub-standalone-test.efi is NOT being currently used

(Anything else?)

From my perspective, the real problem is 2) since it's using the default
setup of the bootloader and kernel.

Without the ability to boot into the Guest, isn't `mkinitrd` in a chrooted
Guest env generally sufficient? Perhaps parameterless mkinitrd isn't ... and
passing specific params to it? I'll take a look; if you have a specific recipe
that should be tried, pls post.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References