Mailinglist Archive: opensuse-bugs (4250 mails)

< Previous Next >
[Bug 1018348] New: DWARF unwinder disabled in 4.9+
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 05 Jan 2017 14:39:49 +0000
  • Message-id: <bug-1018348-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1018348


Bug ID: 1018348
Summary: DWARF unwinder disabled in 4.9+
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
Assignee: jslaby@xxxxxxxx
Reporter: jslaby@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
CC: jeffm@xxxxxxxx, jkosina@xxxxxxxx
Found By: ---
Blocker: ---

Earlier this week I found out that tumbleweed has dwarf unwinder disabled. This
happened when 4.9 was merged, as 4.9 stack dumping was completely rewritten by
Josh. The old unwinder is thus completely incompatible with the current code.

As a part of my work on dwarf unwinding (esp. assembly CFI annotations support
in objtool), I am fixing things up. I almost finished the port of our unwinder
to 4.9+.

I am only creating this as a tracker and as a heads-up that something is going
on.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages