Mailinglist Archive: opensuse-bugs (4243 mails)

< Previous Next >
[Bug 1013647] dell 7470 - trackpoint issues
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 02 Jan 2017 18:39:24 +0000
  • Message-id: <bug-1013647-21960-MFkPwSkB7r@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1013647
http://bugzilla.opensuse.org/show_bug.cgi?id=1013647#c12

Martin Wilck <martin.wilck@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |martin.wilck@xxxxxxxx

--- Comment #12 from Martin Wilck <martin.wilck@xxxxxxxx> ---
Works for me on Tumbleweed.

kernel-default-4.9.0-2.1.x86_64
xorg-x11-server-7.6_1.18.4-2.1.x86_64
libinput10-1.5.3-1.1.x86_64

"xinput set-prop 16 'libinput Accel Speed' -1.0" worked fine, pointer movement
was clearly non-linear. I have no problems with the trackpoint buttons
(assuming this denotes the buttons located between the touchpad and the
keyboard on the E7470).

The only problem with "xinput set-prop 16 'libinput Accel Speed' -1.0" is that
it's the lowest possible setting and may still be too fast for some, depending
on preferences. An udev rule can be used to adjust the normal level (Accel
Speed = 0.0):

ACTION=="add|change", KERNEL=="event[0-9]*", ENV{ID_INPUT_POINTINGSTICK}=="?*",
ENV{POINTINGSTICK_CONST_ACCEL}="0.5"

(https://wayland.freedesktop.org/libinput/doc/latest/udev_config.html)

With these settings, the track point is still no precision device, but I'd say
that's not what it was made for.

Btw, kernel changes to modify the device speed seem to be deprecated upstream:

https://git.kernel.org/cgit/linux/kernel/git/dtor/input.git/commit/drivers/input/mouse/alps.c?id=088df2ccef75754cc16a6ba31829d23bcb2b68ed

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >