Mailinglist Archive: opensuse-bugs (3349 mails)

< Previous Next >
[Bug 973756] Network is not working in OpenSuse Tumbleweed Aarch64 for Gigabyte MP30-AR0 (APM X-Gene 1)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 17 May 2016 10:05:22 +0000
  • Message-id: <bug-973756-21960-5UXcgtOcfd@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=973756
http://bugzilla.suse.com/show_bug.cgi?id=973756#c21

--- Comment #21 from Loic Devulder <loic.devulder@xxxxxxxxxxx> ---
(In reply to Matthias Brugger from comment #19)
(In reply to Matthias Brugger from comment #17)
This is a bug in the clk tree implementation.


After digging deeper into this, I don't think that it is a clk tree
implementation bug, but a bug in the device tree node passed from the FW to
the kernel.

Can you please check the status of the xgene-menet node:
cat /proc/device-tree/soc/ethernet@17020000/status

I can see this node is disabled on the Gigabyte machine. This leads to the
fact, that the kernel does not enable the clocks connected with this device
(ethclk, menetclk).

Can you please double check this on your machine, as I suppose that the FW
is slightly different.

The same as Ronald here (using AMI APTIO UEFI firmware):
ylxl1140:/proc/device-tree/soc # for ETH in ethernet@1*; do echo -n "${ETH}:
";cat ${ETH}/status; echo; done
ethernet@17020000: disabled
ethernet@1f210000: ok
ethernet@1f210030: ok
ethernet@1f610000: ok
ethernet@1f620000: ok

I also tried to change the device tree by passing a dtd file on the boot based
on the Mustang APM device tree but with no success (but it was with a Tianocore
UEFI firmware, not AMI).

I used the clk_ignore_unused parameter but it didn't work on one of my servers.
The working server has the 4.5.2-1-default kernel and the non working has
4.5.0-3-default. The two servers have an AMI APTIO UEFI fimware with the same
version (and the BMC version fw is at the right level too).
I done multiple resets without success but after I tried to re-configure the
BIOS/UEFI, save it and restart. After this the network was ok (with the
clk_ignore_unused parameter)! I have tried without the clock parameter but
without success.

The device tree bug sounds good by why all are working well when the driver is
compiled in the kernel?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >