Mailinglist Archive: opensuse-bugs (3349 mails)

< Previous Next >
[Bug 973756] Network is not working in OpenSuse Tumbleweed Aarch64 for Gigabyte MP30-AR0 (APM X-Gene 1)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 17 May 2016 03:56:06 +0000
  • Message-id: <bug-973756-21960-a6sSSTu1nZ@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=973756
http://bugzilla.suse.com/show_bug.cgi?id=973756#c20

--- Comment #20 from Ronald Maas <ronaldjmaas@xxxxxxxxx> ---
(In reply to Matthias Brugger from comment #19)
(In reply to Matthias Brugger from comment #17)
This is a bug in the clk tree implementation.


After digging deeper into this, I don't think that it is a clk tree
implementation bug, but a bug in the device tree node passed from the FW to
the kernel.

Can you please check the status of the xgene-menet node:
cat /proc/device-tree/soc/ethernet@17020000/status

I can see this node is disabled on the Gigabyte machine. This leads to the
fact, that the kernel does not enable the clocks connected with this device
(ethclk, menetclk).

Can you please double check this on your machine, as I suppose that the FW
is slightly different.

There are 5 ethernet adapters on the board:
ls -la /proc/device-tree/soc/ | grep ether
drwxr-xr-x 3 root root 0 May 16 19:49 ethernet@17020000 ---> BMC
management
drwxr-xr-x 2 root root 0 May 16 19:50 ethernet@1f210000 ---> eth0 1Gbps
drwxr-xr-x 2 root root 0 May 16 19:50 ethernet@1f210030 ---> eth1 1Gbps
drwxr-xr-x 2 root root 0 May 16 19:50 ethernet@1f610000 ---> eth2 10Gbps
drwxr-xr-x 2 root root 0 May 16 19:50 ethernet@1f620000 ---> eth3 10Gbps

cat /proc/device-tree/soc/ethernet@17020000/status
disabled

cat /proc/device-tree/soc/ethernet@1f210000/status
ok

cat /proc/device-tree/soc/ethernet@1f210030/status
ok

cat /proc/device-tree/soc/ethernet@1f610000/status
ok

cat /proc/device-tree/soc/ethernet@1f620000/status
ok

So only the ethernet adapter used to connect to the BMC web console is
disabled. The other ethernet adapters eth0 up to eth3 are properly enabled by
UEFI.

Same result with and without "clk_ignore_unused" kernel parameter.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >