Mailinglist Archive: opensuse-bugs (3349 mails)

< Previous Next >
[Bug 978053] New: Full-require wicked from wicked-service
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 02 May 2016 13:04:46 +0000
  • Message-id: <bug-978053-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=978053


Bug ID: 978053
Summary: Full-require wicked from wicked-service
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.1
Hardware: x86-64
OS: Linux
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: Network
Assignee: wicked-maintainers@xxxxxxx
Reporter: jengelh@xxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

On NetworkManager and systemd-networkd systems, wicked is (of course) not a
runtime requirement. So I thought: rpm -e wicked libwicked-0-6, and indeed this
succeeds.

However, on `zypper up` bringing in a wicked-service update, wicked gets
installed again, even if --no-recommends is used, which is a bit puzzling. It
appears that this is all due to wicked-service's use of Requires(pre): %name =
%version. So at least that's explained.

The split between wicked.rpm and wicked-service.rpm is not quite clear to me.
wicked-service is useless without wicked, and should perhaps have a full
Requires: rather than just Requires(pre):. Or perhaps even merge the two,
because /sbin/ifup is probably not going to work either with NM/networkd. (Or
is it? Then perhaps ifup should be split.) What do you think?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages