Mailinglist Archive: opensuse-bugs (4510 mails)

< Previous Next >
[Bug 964184] different CUPS versions result different printout when wrong printing options are specified
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 15 Feb 2016 20:58:23 +0000
  • Message-id: <bug-964184-21960-4Ro0tB5A9a@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=964184
http://bugzilla.opensuse.org/show_bug.cgi?id=964184#c7

--- Comment #7 from Roland Wirth <roland_wirth@xxxxxx> ---
Note that the CUPS 1.5.4 output of
lp -d testq -o fit-to-page -o orientation-requested=0 original.pdf
is not "wrong" and the CUPS 1.7.5 is "right" - it is just
a random result when wrong options are used (i.e. it is
an implementation detail what the result is).
Basically, the implementation should ignore unknown option values and treat
them as unsupported attributes (if I read RFC2911 correctly).

By the way:
I do not think that it is CUPS that sends an invalid orientation-requested
value - I think that value originated from okular and CUPS only forwards
the print job with its option values as it was created by okular.
The option does not come directly from Okular. I tried to print the same file
via evince, which works as expected although I see the
`orientation-requested=0` in the filter parameters. The difference is that
evince sends a PDF to the server and triggers a different filter chain.

Regarding the main issue:
Okular seems to use contradicting printing options.

To find out whether or not okular actually
use contradicting printing options, set up a test queue
on your workstation that outputs PostScript into a file: [...]
I tried printing to the test queue and for some reason I no longer see the
orientation-requested option (fit-to-page is present). The printouts from
ghostscript are as expected, the only difference between okular and lp being
that the lp printout is in landscape orientation while okular prints portrait
(the paper orientation in okular was set to landscape; strange).

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >