Mailinglist Archive: opensuse-bugs (4510 mails)

< Previous Next >
[Bug 965284] devel:tools:scm:svn/RapidSVN: stopped compiling
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 09 Feb 2016 16:05:58 +0000
  • Message-id: <bug-965284-21960-ew2ryFwg0a@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=965284
http://bugzilla.suse.com/show_bug.cgi?id=965284#c3

--- Comment #3 from Andreas Stieger <astieger@xxxxxxxx> ---
(In reply to Lars Heide from comment #2)
thank you for your efforts. What I do not understand is why the dependency
can not be satisfied as subversion-devel < 1.9.0 is clearly part of the base
installation (even Leap still has subversion 1.8). Why is that not resolved?

Because devel:tools:scm:svn/subversion is found first, and is configured to be
used for all builds in the same project. This is intentional and required to
build a distribution and a set of packages consistently.

Can I not build against dependencies in the base system if they are also
part of the project?

Sure, you would need to change the build configuration (add a path node) or
build against a pure release, not the project.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >