Mailinglist Archive: opensuse-bugs (4504 mails)

< Previous Next >
[Bug 963700] Base:System/glibc: Bug Request version bump to GLIBC v >= 2.23, and backport/cherrypick for Leap
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 09 Feb 2016 14:25:51 +0000
  • Message-id: <bug-963700-21960-4yU1CIAJr2@http.bugzilla.novell.com/>
http://bugzilla.novell.com/show_bug.cgi?id=963700
http://bugzilla.novell.com/show_bug.cgi?id=963700#c7

Michael Matz <matz@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |9b3e05a5@xxxxxxxxx
Flags| |needinfo?(9b3e05a5@xxxxxxxx
| |m)

--- Comment #7 from Michael Matz <matz@xxxxxxxx> ---
I think this problem can only be caused when you use a GCC that is built
against a different glibc than what you're using. GCC contains checks
at build time for buggy glibc headers and includes compatibility code
when they are there (e.g. on old glibc). This compat code will in turn
lead to compile errors when the glibc headers are fixed (e.g. you using
a newer glibc than what GCC was built against). The same problem exists
when GCC is built against a newer glibc than what is then actually installed
at your system.

So, you say your GCC comes from devel:gcc, and your glibc from Leap.
Please state exactly which versions, and from which repos you have both
packages. In particular verify that your GCC comes from the openSUSE_Leap_41.1
sub-repo of devel:gcc, not e.g. from openSUSE_Factory. rpm -qi is your friend.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >