Mailinglist Archive: opensuse-bugs (4498 mails)

< Previous Next >
[Bug 957383] request GRUB2 config option to set needed EFI loader options/flags
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 01 Feb 2016 06:49:46 +0000
  • Message-id: <bug-957383-21960-0D3o8Z4BM8@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=957383
http://bugzilla.opensuse.org/show_bug.cgi?id=957383#c12

Michael Chang <mchang@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Flags|needinfo?(mchang@xxxxxxxx) |

--- Comment #12 from Michael Chang <mchang@xxxxxxxx> ---
(In reply to boo35 boo35 from comment #10)
per earlier comment

maybe prefixed with 'SUSE_' (if deemed unavoidable).

it seems that your patch uses the prefix. What's the argument for prefixing
here? Should this be pushed to upstream instead, or at least, later?

The SUSE_ is for the feature of chain-loading the xen hypervisor via uefi xen
loader which itself a loader and can really be configured separately as
different loader. Upstream is working on the direct UEFI multiboot2 support for
the xen hypervisor to have it loaded via grub2 native multiboot protocol. The
patches we made actually was to ease the integration by yast2 and perl
bootloader which uses unified tools from grub2-utils and share the defaults
from common place (/etc/default/grub) so that it's doesn’t need to understand
how to derive configs from one to another (And grub2 upstream wouldn't depend
on how xen loader configs would be generated). Once the multiboot2 support
merged, these changes could be reverted to use multiboot2 and leave the xen
loader and separated boot path (eg, installed via old style SLE11 scripts).

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >