Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 875814] New: rubygemsdeps.rb automatic dependency system is flawed
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 30 Apr 2014 11:09:55 +0000
  • Message-id: <>

Summary: rubygemsdeps.rb automatic dependency system is flawed
Classification: openSUSE
Product: openSUSE Factory
Version: 13.2 Milestone 0
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Ruby
AssignedTo: ruby-devel@xxxxxxx
ReportedBy: aspiers@xxxxxxxx
QAContact: qa-bugs@xxxxxxx
CC: coolo@xxxxxxxx, kkaempf@xxxxxxxx, jreidinger@xxxxxxxx
Found By: Development
Blocker: ---

As described in
rubygemsdeps.rb will translate requirements from .gemspec files too loosely,

s.add_dependency "net-ssh", ">= 2.6.6", "< 2.8.0"

translates to the following rpm Requires:

auto: rubygem(1.9.1:net-ssh) >= 2.6.6
auto: rubygem(1.9.1:net-ssh) < 2.8.0

which zypper can falsely satisfy by installing both of these together:


One workaround suggested on opensuse-ruby is to make gem2rpm also generate
conflicts, so we'd end up with

Requires: foo >= 2.6.0
Conflicts: foo >= 2.8

but that has the disadvantage of generating unnecessary conflicts, e.g. it
excludes the valid solution of having net-ssh 2.6.6 and 2.8.1 both installed at

It looks like rpm will improve enough to help with this at some point soon-ish:

P.S. sorry if I got the wrong bugzilla product/component/version - wasn't sure
where this belongs.

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages