Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 874153] update the openSUSE installer look and feel (based on SLE12)

https://bugzilla.novell.com/show_bug.cgi?id=874153

https://bugzilla.novell.com/show_bug.cgi?id=874153#c6


--- Comment #6 from Josef Reidinger <jreidinger@xxxxxxxx> 2014-04-29 08:23:09
UTC ---
(In reply to comment #4)
Close it - but we had some discussions in Dubrovnik that it would be great if
the qss had a way to expand variables for colors.

I experimented with css preprocessors, but they are all erroring on qss
specifics (some of them are really stupid, e.g. rgba() not being the same as
in
css).

So I wonder if we can add some basic preprocessing in libyui-qt, so we can
adapt colors easier.

I think it is not good idea to have preprocessing in libyui-qt, but if we
really need it, we can create own simple tool in ruby, where it is quite easy
to create preprocessor and there is actually a lot of existing for css, so
maybe we need just adapting it to generate qss instead of css.

BTW if we need just color processing, then we can use something like mentioned
here
http://stackoverflow.com/questions/10898399/using-variables-in-qt-stylesheets
and if it is really needed, we can also add some basic operations here. But
really keep preprocessor outside of libyui-qt because someone else can also use
it and libyui-qt is already quite complicate, so keep using native qss file
directly

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References