Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 832737] zypper [in,dup,rm,se,ve] segmentation fault

https://bugzilla.novell.com/show_bug.cgi?id=832737

https://bugzilla.novell.com/show_bug.cgi?id=832737#c44


--- Comment #44 from Felix Miata <mrmazda@xxxxxxxxxxxxx> 2014-04-25 03:58:06
EDT ---
using 32 bit 12.3 running kernel-default-3.7.10-1.16 with
libzypp-12.16.4-1.33.1
zypper-1.8.24-1.26.1
zypper -v up with more than 3 locks set segfaulted after refreshing but before
beginning to list packages it wants an answer y to (while "reading installed
packages"?), but works as expected with only 3 locks set.

using 32 bit 13.1 running kernel-default-3.11.10-7 with
libzypp-13.9.0-13.1
zypper-1.9.12-16.1
zypper -v up with a 3433 byte locks file (41 entries, including kernel* as #40,
with firefox-esr as #41) worked as expected. Just afterward, zypper rl kernel*;
zypper -v up segfaulted after "Reading installed packages..." appeared on
screen. Removing the locks file, then zypper al seamonkey; zypper se -s
kernel-default; zypper ll; zypper -v up succeeded to upgrade kernel-firmware.

using 32 bit Factory running kernel-default-3.14.rc7 with
libzypp-14.17.5-1.1
zypper-1.11.4-1.1
zypper -v dup with a 3726 byte locks file (45 locks, including kernel* as #45),
followed by zypper rl kernel*; zypper -v dup all worked as expected.

8 days ago on same machine, urpmi --auto-select on Cauldron and yum upgrade on
Rawhide again worked fine too.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >