Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 874566] New: pidgin doesn't connect to XMPP server using encryption
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 22 Apr 2014 08:03:46 +0000
  • Message-id: <bug-874566-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=874566

https://bugzilla.novell.com/show_bug.cgi?id=874566#c0


Summary: pidgin doesn't connect to XMPP server using encryption
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: juanjo@xxxxxxxxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101
Firefox/28.0

After upgrade openssl (heartbleed bug) pidgin cannot connect to any jabber/xmpp
server using encryption.

The same problem happens in serveral machines in my office.

This is the output when run piding in debug mode:

(09:48:42) account: Connecting to account YYYYYYYY/linux-tx09.site.
(09:48:42) connection: Connecting. gc = 0x7fd07bfb40e0
(09:48:42) dnsquery: Performing DNS lookup for XXXXXXXXXXXXX
(09:48:42) dns: Created new DNS child 4842, there are now 1 children.
(09:48:42) dns: Successfully sent DNS request to child 4842
(09:48:42) dns: Got response for 'XXXXXXXXXXXXXX'
(09:48:42) dnsquery: IP resolved for XXXXXXXXXXXXXX
(09:48:42) proxy: Attempting connection to XXXXXXXXXXXX
(09:48:42) proxy: Connecting to XXXXXXXXXXXXX:5222 with no proxy
(09:48:42) proxy: Connection in progress
(09:48:42) proxy: Connecting to XXXXXXXXXXX:5222.
(09:48:42) proxy: Connected to XXXXXXXXXXXX:5222.
(09:48:42) jabber: Sending (YYYYYYYYYYY/linux-tx09.site): <?xml version='1.0'
?>
(09:48:42) jabber: Sending (YYYYYYYYYYY/linux-tx09.site): <stream:stream
to='puertos.es' xmlns='jabber:client'
xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
(09:48:42) jabber: Recv (513): <?xml version='1.0'
encoding='UTF-8'?><stream:stream
xmlns:stream="http://etherx.jabber.org/streams"; xmlns="jabber:client"
from="ZZZZZZZ" id="b35dbf" xml:lang="en"
version="1.0"><stream:features><starttls
xmlns="urn:ietf:params:xml:ns:xmpp-tls"></starttls><mechanisms
xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism></mechanisms><compression
xmlns="http://jabber.org/features/compress";><method>zlib</method></compression><auth
xmlns="http://jabber.org/features/iq-auth"/></stream:features>
(09:48:42) jabber: Sending (YYYYYYYYYYY/linux-tx09.site): <starttls
xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
(09:48:42) jabber: Recv (50): <proceed
xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
(09:48:42) gnutls: Starting handshake with XXXXXXXXXXX
(09:48:43) docklet: embedded
...
...
dns[4842]: nobody needs me... =(

The server is running fine and other pidgin clients from differents gnu/linux
distros can connect.

We are using this packages:

pidgin-2.10.9-4.10.2.x86_64
pidgin-plugin-guifications-2.16-4.4.1.x86_64
libopenssl1_0_0-32bit-1.0.1e-1.44.1.x86_64
openssl-1.0.1e-1.44.1.x86_64
libgnutls28-3.0.28-1.8.1.x86_64
libopenssl1_0_0-1.0.1e-1.44.1.x86_64
pidgin-guifications-lang-2.16-4.4.1.noarch


Reproducible: Always

Steps to Reproduce:
1. Configure a XMPP client with encryption in pigdin
2. Open pidgin and try to connect
Actual Results:
Pidgin xmpp account cannot connect

Expected Results:
Pidgind should connect.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >