Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 872715] New: depmod segfault at .ko in dependency cycle.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 9 Apr 2014 09:19:18 +0000
  • Message-id: <bug-872715-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=872715

https://bugzilla.novell.com/show_bug.cgi?id=872715#c0


Summary: depmod segfault at .ko in dependency cycle.
Classification: openSUSE
Product: openSUSE Factory
Version: 13.2 Milestone 0
Platform: armv7
OS/Version: openSUSE 13.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: matwey.kornilov@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101
Firefox/28.0

Hi,

I am trying to build kiwi-image for the board
(https://build.opensuse.org/package/show/home:matwey:beaglebone132/JeOS-beaglebone),
the following is the part of buildlog:

[ 384s] Retrieving package kernel-default-3.14.0-1.1.armv7hl (227/276), 29.7
MiB ( 94.0 MiB unpacked)
[ 403s] (227/276) Installing: kernel-default-3.14.0-1.1 [.............done]
[ 403s] Additional rpm output:
[ 403s] warning:
/var/cache/kiwi/packages/usr_src_packages_SOURCES_repos_openSUSE:Factory:ARM_standard/kernel-default.rpm:
Header V3 RSA/SHA256 Signature, key ID 3dbdc284: NOKEY
[ 403s] Free diskspace below /boot: 22107064 blocks
[ 403s] depmod: WARNING: found 6 modules in dependency cycles!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/phy/phy-generic.ko in
dependency cycle!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/core/usbcore.ko in dependency
cycle!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/musb/musb_hdrc.ko in
dependency cycle!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/musb/tusb6010.ko in dependency
cycle!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/gadget/udc-core.ko in
dependency cycle!
[ 403s] depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/usb-common.ko in dependency
cycle!
[ 403s] /usr/lib/module-init-tools/weak-modules2: line 63: 3815 Segmentation
fault "$@"

I am not sure whether it is bug in depmod or kernel, but it leads to the
following behaviour. The initrd of the image built with this kernel/depmod
doesn't have proper modules.dep. And initrd fails to load any modules at start,
including module for root-partition.

I was advised to use KIWI-rescue kernel option and now I am able to get an
shell to the initrd. So, using depmod leads to the same result:

(none):/ # depmod -a
depmod: WARNING: found 6 modules in dependency cycles!
depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/phy/phy-generic.ko in
dependency cycle!
depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/core/usbcore.ko in dependency
cycle!
depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/musb/musb_hdrc.ko in
dependency cycle!
depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/musb/tusb6010.ko in dependency
cycle!
depmod: WARNING:
/lib/modules/3.14.0-1-default/kernel/drivers/usb/gadget/udc-core.ko in
dependency cycle!
depmod: WARNING: /lib/modules/3.14.0-1-default/kernel/drivers/usb/usb-common.ko
in dependency cycle!
Segmentation fault
(none):/ # depmod --version
kmod version 16
(none):/ # uname -a
Linux (none) 3.14.0-1-default #1 SMP Fri Apr 4 14:42:45 UTC 2014 (00dd4e3)
armv7l armv7l armv7l GNU/Linux



Reproducible: Always

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >