Mailinglist Archive: opensuse-bugs (5295 mails)

< Previous Next >
[Bug 851984] After update (zypper dup) AppArmor profiles for dovecot have to be manually removed to make dovecot work

https://bugzilla.novell.com/show_bug.cgi?id=851984

https://bugzilla.novell.com/show_bug.cgi?id=851984#c2


--- Comment #2 from Franz Häuslschmid <lukrez.forums@xxxxxxx> 2013-11-23
14:59:22 UTC ---
(In reply to comment #1)
(In reply to comment #1)
which hinted me at AppArmor denying access to "doveconf". Using the
appropriate YaST section, I removed all profiles referring to dovecot.
After
that, dovecot started and worked as expected. I wondered whether
reinstalling
the AppArmor profiles would break dovecot again and tried:

zypper in -f apparmor-profiles

and after that

systemctl restart dovecot.service

With the fresh profiles from the repository, dovecot still works.

Do you have any *.rpmnew or *.rpmorig in /etc/apparmor.d/ ? That would explain
why deleting and re-installing the dovecot profiles worked.

BTW: Did you reload the profiles after re-installing the apparmor-profiles
package ("rcapparmor reload")? IIRC the package doesn't do that automatically.

Thank you for your comment. I did actually not reload the profiles explicitly
and had to discover that my "solution" to reinstall the profiles, would have
prevented dovecot from working on the next reboot.

For me, the AppArmor profiles for dovecot in 13.1 are not working. Now I have
removed again the profiles concerning dovecot and it works again.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References