Mailinglist Archive: opensuse-bugs (5295 mails)

< Previous Next >
[Bug 851984] After update (zypper dup) AppArmor profiles for dovecot have to be manually removed to make dovecot work

https://bugzilla.novell.com/show_bug.cgi?id=851984

https://bugzilla.novell.com/show_bug.cgi?id=851984#c1


--- Comment #1 from Christian Boltz <suse-beta@xxxxxxxxx> 2013-11-23 14:20:24
CET ---
(In reply to comment #1)
which hinted me at AppArmor denying access to "doveconf". Using the
appropriate YaST section, I removed all profiles referring to dovecot. After
that, dovecot started and worked as expected. I wondered whether reinstalling
the AppArmor profiles would break dovecot again and tried:

zypper in -f apparmor-profiles

and after that

systemctl restart dovecot.service

With the fresh profiles from the repository, dovecot still works.

Do you have any *.rpmnew or *.rpmorig in /etc/apparmor.d/ ? That would explain
why deleting and re-installing the dovecot profiles worked.

BTW: Did you reload the profiles after re-installing the apparmor-profiles
package ("rcapparmor reload")? IIRC the package doesn't do that automatically.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References