Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827526] New: "firewire ERR: Incompatible libffado version! (libffado 2.1.0-)" when launching "jackd -dfirewire"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 30 Jun 2013 19:18:46 +0000
  • Message-id: <bug-827526-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827526

https://bugzilla.novell.com/show_bug.cgi?id=827526#c0


Summary: "firewire ERR: Incompatible libffado version!
(libffado 2.1.0-)" when launching "jackd -dfirewire"
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Major
Priority: P5 - None
Component: Sound
AssignedTo: tiwai@xxxxxxxx
ReportedBy: lpgasparotto@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.14

When launching "jackd -dfirewire" I get this output:

jackdmp 1.9.8
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
firewire ERR: Incompatible libffado version! (libffado 2.1.0-)
Cannot initialize driver
JackServer::Open() failed with -1
no message buffer overruns
Failed to open server

It's impossible to launch Jack server due this issue.

Reproducible: Always

Steps to Reproduce:
1.Plug your firewire audio device (jackd and ffado should be previously
installed)
2.Open a terminal and type "jackd -dfirewire"
3.
Actual Results:
jackdmp 1.9.8
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
firewire ERR: Incompatible libffado version! (libffado 2.1.0-)
Cannot initialize driver
JackServer::Open() failed with -1
no message buffer overruns
Failed to open server

Expected Results:
Jack server should start and give information about the plugged firewire
device.

The version of jack in openSUSE 12.3 has this line:
#define FIREWIRE_REQUIRED_FFADO_API_VERSION 8

and requires exactly this version. But ffado-2.1.0 has FFADO_API_VERSION of 9

There's a patched version at this repository:
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/openSUSE:/12.3:/Update/openSUSE_Tumbleweed/

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >