Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827504] New: ocfs2console doesn't start
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 29 Jun 2013 20:31:14 +0000
  • Message-id: <bug-827504-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827504

https://bugzilla.novell.com/show_bug.cgi?id=827504#c0


Summary: ocfs2console doesn't start
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: werner.flamme@xxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101
Firefox/22.0

Whenever I try to invoke ocfs2console, I only get

Traceback (most recent call last):
File "/usr/sbin/ocfs2console", line 33, in <module>
from ocfs2interface.console import main
File "/usr/lib64/python2.7/site-packages/ocfs2interface/console.py", line 26,
in <module>
from mount import mount, unmount
File "/usr/lib64/python2.7/site-packages/ocfs2interface/mount.py", line 20,
in <module>
import ocfs2
ImportError: /usr/lib64/python2.7/site-packages/ocfs2interface/ocfs2module.so:
undefined symbol: io_queue_release


Reproducible: Always

Steps to Reproduce:
1. enter the command "ocfs2console"
2. look at the error

Actual Results:
ocfs2console does not start up. It seems to be a problem inside the
ocfs2-modules of python. All files mentioned in the error belong to the package
ocfs2console-1.8.2-4.4.1.x86_64, which I installed from the OSS-update repo.

Expected Results:
I expect the prgram ocfs2console to run.

Currently, there is no way to add more than one node to
/etc/ocfs2/cluster.conf. The functionality of o2cb and o2cb_ctl is broken here,
and ocfs2console does not run (so I can_t even check if this program was able
to add nodes to the cluster). Adding them with an editor does not show them in
the cluster config. See also bugs 822190 and 827479.

Adding the respective subdirectories in
/sys/kernel/config/cluster/<clustername>/node and writing the values into the
files does not help either.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages