Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827481] New: Installer doesn't reflect changes done to the partition table and puts wrong swap entry into fstab (on RAID 0)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 29 Jun 2013 11:22:11 +0000
  • Message-id: <bug-827481-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827481

https://bugzilla.novell.com/show_bug.cgi?id=827481#c0


Summary: Installer doesn't reflect changes done to the
partition table and puts wrong swap entry into fstab
(on RAID 0)
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: tobiaspotocek@xxxxxxxxx
QAContact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=546245)
--> (http://bugzilla.novell.com/attachment.cgi?id=546245)
Yast Installation Log

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101
Firefox/21.0

During the installation, I canceled proposed partition setup and created my
own. The problem was that the installer (probably) didn't notice those changes
and put an old entry for swap partition into fstab.

See attached Yast2 log, line 2582. There should be /dev/md125p7 instead of
/dev/md126p7.

My guess is also that this is related to the fact that I'm running OpenSuse on
RAID 0 (which hasn't been created by OpenSuse).

Reproducible: Always

Steps to Reproduce:
1. Start OpenSuse 12.3 installer (on a machine with RAID 0)
2. Go to expert mode in partition setup
3. Delete all proposed partitions and create your own setup
4. Confirm and proceed rest of the installation as usual
Actual Results:
Wrong swap entry is put into fstab => swap doesn't work..

Another result is that OpenSuse hangs during the startup process trying to
mount the missing swap partition until time limit is exceeded, i. e. the boot
up process is very slow. That was the original symptom which lead to this
discovery.

Expected Results:
Swap should be properly configured

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups