Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827289] New: UEFI system 1st reboot during installation always goes to Windows8 and not to grub2
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 28 Jun 2013 11:42:43 +0000
  • Message-id: <bug-827289-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827289

https://bugzilla.novell.com/show_bug.cgi?id=827289#c0


Summary: UEFI system 1st reboot during installation always goes
to Windows8 and not to grub2
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: Installation
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: lee_matheson@xxxxxxxxxxx
QAContact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101
Firefox/21.0

During installation from an openSUSE-12.3 DVD install .iso (using a USB-3.0
memory stick in a USB-3.0 port) on a Toshiba Satellite Z930 (which had a UEFI
enabled firmware) the 1st reboot of the SSD drive during installation always
goes to Windows8 and not to grub2. This was true for both secure boot enabled
and for secure boot disabled in the UEFI firmware. During install secure boot
was selected and grub2-efi was also selected.

In the end, the solution that worked was to boot to an openSUSE liveDVD and
copy the contents of the EFI/opensuse to the EFI/boot and also to rename the
'shim.efi' to 'bootx64.efi' (replacing the existing bootx64.efi). After that,
when rebooting to the SSD drive the installation then continued successfully.
The PC has been running openSUSE-12.3 well since with secure boot enabled or
disabled.

Speculation: This is possibly due to a Toshiba quirk in their UEFI
implementation (Toshiba firmware v.6.70) on this Toshiba Satellite Z930
ultrabook.

Possibly consider an openSUSE enhancement with an option of a more user
friendly way to do this bootx64.efi replacement with shim.efi (assuming that
this is the appropriate work around and that no better method available).

Reproducible: Always

Steps to Reproduce:
1. Do a fresh install of openSUSE-12.3 with secure boot enabled (or disabled)
on a Toshiba Satellite Z930
2. Proceed with 1st reboot after software install complete (but before
installation configuration is complete).
3.
Actual Results:
After os s/w install during 1st reboot only Windows8 will boot.

Expected Results:
Installation via grub2 should continue and windows8 should NOT continue booting
regardless.

Obtained help on openSUSE forums to find the functional work around:
https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/485517-opensuse-windows8-dual-boot-installation-questions-secure-boot-uefi-gpt-2.html
(problem starting at post#78). That's a long thread so I don't expect bug
report users to read the thread !

In windows8 I tried (with admin permissions) sending the command:
bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi
while that reported successful, the Toshiba still rebooted to Windows8

The Windows8 command:
efibootmgr -v
yielded:
linux:/home/linux # efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0006,0005,0003,0000,0004,0002,0001
Boot0000* HDD/SSD ACPI(a0341d0,0)PCI(1f,2)ATAPI(0,0,0)
Boot0001* LAN2
ACPI(a0341d0,0)PCI(19,0)MAC(e8e0b773c368,0)IPv4(0.0.0.0:0<->0.0.0.0:0,0, 0
Boot0002* LAN1
ACPI(a0341d0,0)PCI(19,0)MAC(e8e0b773c368,0)030d3c000000000000000000000000000000000000000000000000000000000000000000000000000000004000000000000000000000000000000000
Boot0003* Windows Boot Manager
HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...9................
Boot0004* USB Memory ACPI(a0341d0,0)PCI(1d,0)USB(0,0)
Boot0005* opensuse
HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\opensuse\grubx64.efi)
Boot0006* opensuse-secureboot
HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\opensuse\shim.efi)

which suggested all was well, but the Toshiba still would boot only to
MS-Windows8.

On the replacement of bootx64.efi with shim.efi appeared to work.

I note everytime grub2 configuration is updated, I need to recopy 'shim.efi'
over 'bootx64.efi' to have the grub2 update applied.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >