Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827230] New: cyrus-sasl + mysql fails with cyrus-sasl-sqlauxprop-2.1.25-24.1.1
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 28 Jun 2013 07:46:10 +0000
  • Message-id: <bug-827230-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827230

https://bugzilla.novell.com/show_bug.cgi?id=827230#c0


Summary: cyrus-sasl + mysql fails with
cyrus-sasl-sqlauxprop-2.1.25-24.1.1
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Network
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: markus.heinze@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101
Firefox/21.0

after setup cyrus-sasl, cyrus-sasl-sqlauxprop, mysql and all required
components (/etc/sasl2/smtpd.conf, mysql tables, postfix etc.) saslauth with
postfix and mysql returned the following error in log

-->
: SQL engine 'mysql' not supported
: auxpropfunc error no mechanism
<--

if you have a look into libsql.so.2.0.25 you can see that there are no exportet
functions for any engine

Reproducible: Always

Steps to Reproduce:
1. setup 12.3 with postfix and cyrus-sasl with sql-auxprop
2. test smtp auth from commandline
telnet localhost 25 , ehlo blablub
3. look into mail log you find the message described above
Actual Results:
no saslauth with mysql backend possible

Expected Results:
saslauthd queries mysql and return true or false for authentication

have a look at bug 784705 from OS12.2 think this is the same behavior
after i've re-compiled the source rpm several times i've found out the patch
'cyrus-sasl-no_rpath.patch' is the problem that prevents libsql.so to compile
correct.
after a post in suse mailing list Christian Boltz gave me the clue

here the solution:

edit the patch 'cyrus-sasl-no_rpath.patch'

change the following line from:
+ andrew_runpath_switch="none"
to
+ andrew_cv_runpath_switch="none"

that's all, all works fine now, hope you can read this, maybe a german
reporting tool would be easier for me ;)

hth
regards max

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups