Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 823024] New: cloud-init is missing init scripts
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 4 Jun 2013 08:15:46 +0000
  • Message-id: <bug-823024-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=823024

https://bugzilla.novell.com/show_bug.cgi?id=823024#c0


Summary: cloud-init is missing init scripts
Classification: openSUSE
Product: openSUSE Factory
Version: 13.1 Milestone 0
Platform: Other
OS/Version: openSUSE 12.3
Status: NEW
Severity: Major
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: juerg.haefliger@xxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=542470)
--> (http://bugzilla.novell.com/attachment.cgi?id=542470)
Sample cloud-init init scripts (need tweaking)

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML,
like Gecko) Chrome/27.0.1453.93 Safari/537.36

cloud-init is designed to run four different stages: 'init local', 'init',
'config modules' and 'config final'. The current OpenSUSE cloud-init package
only contains a single init script that runs the 'init' stage but none of the
others.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:
Local config setting are not applied, config modules and final modules are not
executed, leaving the VM in a partially configured state.

Expected Results:
All stages should be executed.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >