Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822770] Install of grub2-efi failed

https://bugzilla.novell.com/show_bug.cgi?id=822770

https://bugzilla.novell.com/show_bug.cgi?id=822770#c13


--- Comment #13 from Andrey Borzenkov <arvidjaar@xxxxxxxxx> 2013-06-03 00:26:23
UTC ---
(In reply to comment #12)
Created an attachment (id=542221)
--> (http://bugzilla.novell.com/attachment.cgi?id=542221) [details]
requested strace output


open("/sys/firmware/efi/vars/new_var", O_WRONLY) = 3
write(3, "B\0o\0o\0t\0000\0000\0000\0003\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"...,
2084) = -1 ENOSPC (No space left on device)


As expected, the command fails.

I then reran the same command on the same box, while running 12.3. And that
worked just fine. If you want a transcript of that, I can attach.


If the same command works on the same system under different kernel version it
becomes kernel issue and has to be reassigned to it.

OTOH in installation logs we have seen that grub2-install apparently worked and
immediately following shim-install failed. Both use the same efibootmgr with
the only difference that grub2-install should point to
\EFI\opensuse_alt\grubx64.efi. Does it fail too? I.e.

efibootmgr -c -d /dev/sda -p 1 -w -L
opensuse_alt-secureboot -l '\EFI\opensuse_alt\shim.efi'

Also you somewhere else suggested that your firmware allows only one boot entry
per hard disk. Could you remove existing boot entries on this ESP and retry?
I'm not sure how many do you have, but at least Windows and openSUSE ones point
to different partitions.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References