Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822777] New: Radeon UVD: [drm:evergreen_startup] *ERROR* radeon: error initializing UVD
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 3 Jun 2013 00:02:16 +0000
  • Message-id: <bug-822777-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=822777

https://bugzilla.novell.com/show_bug.cgi?id=822777#c0


Summary: Radeon UVD: [drm:evergreen_startup] *ERROR* radeon:
error initializing UVD
Classification: openSUSE
Product: openSUSE Factory
Version: 13.1 Milestone 0
Platform: i686
OS/Version: openSUSE 12.3
Status: NEW
Severity: Major
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: kt3107@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=542201)
--> (http://bugzilla.novell.com/attachment.cgi?id=542201)
current dmesg on broken UVD

User-Agent: Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101
Firefox/21.0

Hi,
i'm using OpenSuse 12.3 with repositories:
http://download.opensuse.org/repositories/home:/pontostroy:/drm-next/openSUSE_12.3
http://download.opensuse.org/repositories/Kernel:/HEAD/standard
http://download.opensuse.org/repositories/home:/pontostroy:/X11/openSUSE_12.3

and get latest radeon's firmwares binaries from git
http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git, there
are uvd-firmwares:
CYPRESS_uvd.bin RV710_uvd.bin SUMO_uvd.bin TAHITI_uvd.bin

I have working UVD decoder on kernel - 3.10.0-rc2-4.g17413bd-desktop, and
broken it in latest kernels - 3.10.0-rc2-5.gd28ac96-desktop and higher.

Reproducible: Always

Steps to Reproduce:
1. Install test brunches described above
2. Boot rom kernel 3.10.0-rc2-5.gd28ac96-desktop or latest
3.10.0-rc3-1.g244eade-desktop
3. see dmesg output: dmesg | grep -i "uvd" , you will see:
[ 3.550980] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
********
[ 12.775927] [drm:evergreen_startup] *ERROR* radeon: error initializing UVD
(-1).
Actual Results:
dmesg | grep -i "uvd"
[ 3.550980] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 4.571632] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 5.592255] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 6.612986] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 7.633596] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 8.654049] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 9.674502] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 10.694958] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 11.715411] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 12.735864] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset
the VCPU!!!
[ 12.755883] [drm:r600_uvd_init] *ERROR* UVD not responding, giving up!!!
[ 12.775927] [drm:evergreen_startup] *ERROR* radeon: error initializing UVD
(-1).

Expected Results:
dmesg | grep -i "uvd"
[ 2.510555] [drm] UVD initialized successful

Laptop Lenovo x130e
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI
Wrestler [Radeon HD 6320]

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >