Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822770] Install of grub2-efi failed

https://bugzilla.novell.com/show_bug.cgi?id=822770

https://bugzilla.novell.com/show_bug.cgi?id=822770#c4


Andrey Borzenkov <arvidjaar@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
InfoProvider| |nrickert@xxxxxxxxxxxxx

--- Comment #4 from Andrey Borzenkov <arvidjaar@xxxxxxxxx> 2013-06-02 10:21:03
UTC ---
I performed test installation using x86_64 DVD on MacBook (Pro?) 3.1 using
direct EFI boot from CD, selecting minimal text installation. I enabled Secure
Boot in bootloader properties. Installation went OK, it installed bootloader
including shim and created EFI boot entries (both opensuse and
opensuse-secureboot). To my surprise they even worked (judged by message during
boot, shim was indeed loaded - you can be sure with Apple :) )

I also tried to set alternate Distributor, but it was ignored. May be I made
mistake.

In your logs the only failure is with shim installation. What makes it quite
puzzling, grub2-install itself works.

2013-06-01 17:41:33 <1> pbl-5222.2 Core::RunCommand.1641: run
/usr/sbin/grub2-install --target=x86_64-efi >/var/log/YaST2/y2log_bootloader
2>&1 - ret 0 + output: Installation finished. No error reported.

2013-06-01 17:41:33 <1> pbl-5222.2 Core::RunCommand.1641: run
/usr/sbin/shim-install --config-file=/boot/grub2/grub.cfg
/var/log/YaST2/y2log_bootloader 2>&1 - ret 256 + output:

Could you test whether shim-install called manually works?

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References