Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 812460] New: Frequent crashes of Amarok 2.7.0 on starting the application
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 29 Mar 2013 13:32:57 +0000
  • Message-id: <bug-812460-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=812460

https://bugzilla.novell.com/show_bug.cgi?id=812460#c0


Summary: Frequent crashes of Amarok 2.7.0 on starting the
application
Classification: openSUSE
Product: openSUSE Factory
Version: 13.1 Milestone 0
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: KDE4 Applications
AssignedTo: kde-maintainers@xxxxxxx
ReportedBy: brack@xxxxxxxxxxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=532648)
--> (http://bugzilla.novell.com/attachment.cgi?id=532648)
Output on STDOUT until the crash

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML,
like Gecko) Chrome/26.0.1410.43 Safari/537.31

I have a fresh install of openSUSE 12.3 and use the amarok package of the
standard openSUSE repository

$ rpm -qi amarok
Name : amarok
Version : 2.7.0
Release : 2.2.1
Architecture: x86_64
Install Date: Sat Mar 16 15:52:22 2013
Group : Productivity/Multimedia/Sound/Players
Size : 22007031
License : GPL-2.0+
Signature : RSA/SHA256, Sun Feb 17 20:38:37 2013, Key ID b88b2fd43dbdc284
Source RPM : amarok-2.7.0-2.2.1.src.rpm
Build Date : Sun Feb 17 20:30:36 2013
Build Host : build13
Relocations : (not relocatable)
Packager : http://bugs.opensuse.org
Vendor : openSUSE
URL : http://amarok.kde.org/
Summary : Media Player for KDE
Description :
Amarok is a media player for all kinds of media. This includes MP3, Ogg
Vorbis, audio CDs, podcasts and streams. Play lists can be stored in
.m3u or .pls files.
Distribution: openSUSE 12.3

Each time I start amarok (from the launcher) it only shows the splash screen
and then crashes. I usually have to give it one two three more tries until the
application comes up. Once it's running, I very rareley get more crashes.

The bug reporting assistant tells me that the collected trace is useless. I
have installed the amarok-debuginfo package and several other multimedia
related debug packages. But the lines at the bottom just show:

Thread 1 (Thread 0x7f304d037780 (LWP 3692)):
[KCrash Handler]
#6 0x00007f2f404f8030 in ?? ()
#7 0x00007f2fb9070da0 in ?? ()
#8 0x0000000000000000 in ?? ()

The symbols of all other threads can be resolved (if they are helpful, I can
provide them later).

If I start amarok fromm a console, the same crash happens. The dump to STDOUT
is attached.

The only other info that I can think of is that my home partition is reused
from several older installations/machines. Last was an openSUSE 12.1 on the
same machine.

If any other info is needed, I'll be glad to provide it.

Thanks in advance,
Ingo

Reproducible: Always

Steps to Reproduce:
1. Start amarok

Actual Results:
A crash with "segmentation fault"

Expected Results:
It should show the main window of amarok

Not sure about the severity. As a crash it might be "critical", but then, after
a handful of tries it works at some point. So I'll leave it at "major" because
it's very annoying.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >