Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 805397] NFS mount is done before eth0 is up

https://bugzilla.novell.com/show_bug.cgi?id=805397

https://bugzilla.novell.com/show_bug.cgi?id=805397#c8


--- Comment #8 from Marius Tomaschewski <mt@xxxxxxxx> 2013-03-25 09:49:30 UTC
---
(In reply to comment #2)
Even though I switched to ifup with yast2, after a reboot NetworkManager is
still running.
Also in /etc/sysconfig/network/config I find as last line: NETWORKMANAGER="no"

What I have to do to resolve this problem is to explicitely deactivate it:
systemctl disable NetworkManager.service

With that the NFS mount works during boot when the Laptop is connected via
eth0.

See also bug #800771:
NETWORKMANAGER=yes/no is gone in in favor of network.service alias link

In 12.3 before final [RC1], yast2 network were unable to switch between
/etc/init.d/network and NetworkManager. As you reported it for a version
before final originally, you may need to fix it manually to ensure that
only one / the desired network service is in use:

1) stop whatever is running:

systemctl stop NetworkManager.service
systemctl stop network.service

2) Enable or disable NetworkManager:

systemctl --force enable NetworkManager.service
or
systemctl --force disable NetworkManager.service

3) Start the currently enabled network service:

systemctl start network.service

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >