Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 811180] New: 'loop' kernel module not always loaded automatically.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 23 Mar 2013 08:15:07 +0000
  • Message-id: <bug-811180-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=811180

https://bugzilla.novell.com/show_bug.cgi?id=811180#c0


Summary: 'loop' kernel module not always loaded automatically.
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: SUSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: poolbarde@xxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101
Firefox/19.0

I have installed 'truecrypt' on my opensuse 12.3 system.
Mounting truecrypt volumes failes until I execute:
modprobe loop

But I found out, that mounting files containing filesystms works fine, and
afterwads mounting truecrypt volumes works fine without using modprobe.

On opensuse 12.2, I always could mount truecrypt volumes without using
modprobe.
So what is the difference? Why is loop module loaded automatically when
mounting filesystem, but not using truecrypt?

Reproducible: Always

Steps to Reproduce:
How it does not work:
1. boot system
2. login
3. start truecrypt
4. mount truecrypt volume fails

How it works:
1. boot system
2. execute 'modprobe loop'
3. start truecrypt
4. mount truecrypt volume works now

A second way that works:
1. boot system
2. login
3. create filesystem in file:
a. dd if=/dev/zero of=./myfilesystem bs=10M count=10
b. mkfs.ext3 ./myfilesystem
4. mount filesystem, there are two options:
a. mount -o loop ./myfilesystem /mnt
b. mount ./myfilesystem /mnt <- soo ooption '-o loop' is not
mandatory - I wonder why?
5. start truecrypt
6. mount truecrypt volume works now, because loop module has been loaded
automatically



Expected Results:
I would expect, that the 'loop' module always is loaded automatically.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups