Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 793954] raid1 array sometimes started with one of two disks at boot (again)

https://bugzilla.novell.com/show_bug.cgi?id=793954

https://bugzilla.novell.com/show_bug.cgi?id=793954#c18


--- Comment #18 from Christian Boltz <suse-beta@xxxxxxxxx> 2013-03-08 01:12:34
CET ---
With the latest package, I get several
boot.md[335]: EBUSY - retrying dev_open of /dev/sda5
boot.md[335]: EBUSY - retrying dev_open of /dev/sdb5
which is not really surprising - sd*5 is part of md2, which is my root
partition and already mounted by initrd. (Nevertheless, wouldn't it make sense
to skip checking partitions that are already in use by an active raid array?)

It also looks like your changes prevented a failure:

Mar 05 12:13:33 geeko.boltz boot.md[316]: mdadm: looking for devices for
/dev/md1
[...]
Mar 05 12:13:35 geeko.boltz boot.md[316]: EBUSY - retrying dev_open of
/dev/sdb3
[...]
Mar 05 12:13:36 geeko.boltz boot.md[316]: mdadm: /dev/sdb3 is identified as a
member of /dev/md1, slot 1.
Mar 05 12:13:36 geeko.boltz boot.md[316]: mdadm: /dev/sda3 is identified as a
member of /dev/md1, slot 0.
Mar 05 12:13:36 geeko.boltz boot.md[316]: mdadm: added /dev/sdb3 to /dev/md1 as
1
Mar 05 12:13:36 geeko.boltz boot.md[316]: mdadm: added /dev/sda3 to /dev/md1 as
0
Mar 05 12:13:37 geeko.boltz boot.md[316]: mdadm: /dev/md1 has been started with
2 drives.

and also helped two days later (Mar 07 12:14:51) with similar log messages.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >