Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 807747] New: Provide RPMs for LSB 4.0 Functional Areas in addition to "Core"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 6 Mar 2013 09:50:27 +0000
  • Message-id: <bug-807747-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=807747

https://bugzilla.novell.com/show_bug.cgi?id=807747#c0


Summary: Provide RPMs for LSB 4.0 Functional Areas in addition
to "Core"
Classification: openSUSE
Product: openSUSE 12.2
Version: Final
Platform: All
OS/Version: openSUSE 12.2
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: Basesystem
AssignedTo: kukuk@xxxxxxxx
ReportedBy: jsmeix@xxxxxxxx
QAContact: qa-bugs@xxxxxxx
CC: jw@xxxxxxxx, pgajdos@xxxxxxxx, idonmez@xxxxxxxx
Found By: Development
Blocker: No


I am only the messenger here - the issue was found
by our libjpeg-turbo maintainer Petr Gajdos, see
https://bugzilla.novell.com/show_bug.cgi?id=807183#c11

This enhancement request asks for additional "lsb" RPMs that
provide the other LSB functional areas in addition to "Core".

According to
http://refspecs.linuxfoundation.org/LSB_4.0.0/LSB-Desktop-generic/LSB-Desktop-generic/libjpeg62.html
the Linux Standard Base Desktop Specification 4.0 requires
a library "libjpeg" with "SONAME: libjpeg.so.62".

But there is no openSUSE RPM for any functional area except "Core"
(LSB 4.0 "Core" is provided by our lsb RPM).

In particular there is no openSUSE RPM for
the Linux Standard Base Desktop Specification 4.0.

The consequence is that third-party RPMs that have a requirement
e.g. for "lsb >= 3.2" can be installed without missing RPM requirements
because our lsb RPM fulfills such a requirement but actually the
third-party RPM may not work e.g. because it requires libjpeg.so.62,
see for example
https://bugzilla.novell.com/show_bug.cgi?id=807183#c2

I am really not a LSB expert so that I don't know if
a third-party RPM requirement for "lsb >= 3.2"
is a requirement for "all LSB functional areas"
or only a requirement for "LSB core".

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >