Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 804070] User can no longer update various, commonly-updated, components on their system.

https://bugzilla.novell.com/show_bug.cgi?id=804070

https://bugzilla.novell.com/show_bug.cgi?id=804070#c19


Andreas Jaeger <aj@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
AssignedTo|bnc-team-screening@xxxxxxxx |idonmez@xxxxxxxx
|ovo.novell.com |

--- Comment #19 from Andreas Jaeger <aj@xxxxxxxx> 2013-03-05 20:26:16 UTC ---
The bug report overall is invalid/wontfix.

From the upstream bug:
And just to be clear, we guarantee binary compatibility across minor
versions, but not across major versions.

So an XS module compiled under 5.14.1 will continue working if the
installed perl is upgraded to 5.14.3, but not if to 5.16.0: it will need
to be recompiled then.

And also:
"The version of perl which your vendor (SUSE, in this case) supplies --
typically as /usr/bin/perl -- is for the *vendor's* use. The vendor is
entitled to use it to run programs that come as part of their
distribution. You, the customer, are permitted to use that, but if your
own needs require you to make heavy use of CPAN distributions or to
periodically upgrade perl to a new major version, then you are better
off building your own perl from source or getting a release tarball from
perl.org and installing perl in some place like /usr/local/bin/perl."

The specific patch you have for vim is something we can add if the vim
maintainers agree.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >