Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 807169] New: qgis Couldn't load PyQGIS
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 2 Mar 2013 18:46:02 +0000
  • Message-id: <bug-807169-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=807169

https://bugzilla.novell.com/show_bug.cgi?id=807169#c0


Summary: qgis Couldn't load PyQGIS
Classification: openSUSE
Product: openSUSE 12.2
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: petersenmde@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101
Firefox/19.0

When starting qgis the following error message is shown:

Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
File "", line 1, in
RuntimeError: the sip module implements API v9.0 to v9.1 but the qgis.core
module requires API v8.1

Python version:
2.7.3 (default, Apr 14 2012, 08:58:41) [GCC]

QGIS version:
1.8.0-Lisboa 'Lisboa', exported

Python path:
['/usr/share/qgis/python', '/home/mark/.qgis//python',
'/home/mark/.qgis//python/plugins', '/usr/share/qgis/python/plugins',
'/usr/lib/python27.zip', '/usr/lib64/python2.7',
'/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk',
'/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload',
'/usr/lib64/python2.7/site-packages',
'/usr/local/lib64/python2.7/site-packages',
'/usr/local/lib/python2.7/site-packages',
'/usr/lib64/python2.7/site-packages/gtk-2.0',
'/usr/lib/python2.7/site-packages',
'/usr/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info',
'/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode']

Reproducible: Always

Steps to Reproduce:
1.Start qgis
2.Error message is displayed
3.
Actual Results:
Python support disabled.

Expected Results:
Python support should be enabled.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups