Mailinglist Archive: opensuse-bugs (4216 mails)

< Previous Next >
[Bug 742772] openSUSE x86_64 Update mirrors have different versions of the same file i.e. libqt4-4.7.4-19.4.1.x86_64.rpm

https://bugzilla.novell.com/show_bug.cgi?id=742772

https://bugzilla.novell.com/show_bug.cgi?id=742772#c4


--- Comment #4 from David Westfall <david.westfall@xxxxxxxxxx> 2012-01-23
12:49:55 UTC ---
It is not that one file is bad or good. It is that the file changed and is not
being pushed through the mirrors because it has the same name, size , and very
close timestamp.

From what I see the file with checksum c7a312... was in the repo first then
changed to the file with checksum 746850... mid January.

I have about 30 files that now fail to update a brand new 12.1 64bit kde
installed.

The computer I built and updated around the 11th updated ok. My mirror was
synced around the 9th for that update.

Problem with the update repo stated from my sync on th 17th.

Below is the list of files that have digest errors when trying to update a new
install. There may be more, these are just from a clean 12.1 64bit install
nothing else added.

This is from one of my posts in the fourm.

****
To fix this the openSUSE team will have to decide which rpm to keep, and then
get the mirrors in sync. There are a few way I can think of to do this.

One, rebuild the RPM's with a forced version number change.

Two, delete the RPM's for a day, then put back in after the mirrors also
delete the RPM's

Three, contact the mirror admin's and have force checksum during sync update.
Since it maybe unknown how may files are out of sync this maybe the best
option. These 30 files are just from a base 64bit kde install, there maybe more
RPM's outof sync.
****

Dave W

device-mapper
krb5
libfreetype6
libqt4
libxml2-python
pam-modules
splashy
systemd
lvm2
ft2demos
libqt4-sql
splashy-branding-openSUSE
systemd-sysvinit
postfix
libqt4-x11
libqt4-sql-sqlite
libqt4-sql-mysql
libqt4-qt3support
polkit-kde-agent-1
okular
libkonq5
konsole
keditbookmarks
plasmoid-folderview
kfind
kdepasswd
kdebase4-libkonq
konqueror-plugins
dolphin
konqueror

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >