Mailinglist Archive: opensuse-bugs (4202 mails)

< Previous Next >
[Bug 738532] pdftops conversion shakes letters

https://bugzilla.novell.com/show_bug.cgi?id=738532

https://bugzilla.novell.com/show_bug.cgi?id=738532#c3


Johannes Meixner <jsmeix@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |jsmeix@xxxxxxxx
Platform|x86-64 |All
AssignedTo|jsmeix@xxxxxxxx |vuntz@xxxxxxxx
Summary|PDF-PS conversion shakes |pdftops conversion shakes
|letters |letters

--- Comment #3 from Johannes Meixner <jsmeix@xxxxxxxx> 2012-01-11 13:51:36 UTC
---
When you print a PDF, the CUPS filtering system runs
first of all /usr/lib/cups/filter/pdftops which is only a wrapper
that calls /usr/bin/pdftops which actually converts PDF to PS.

I can reproduce it when I run with your attachment #468903
----------------------------------------------------------------
pdftops test.pdf pdftops-test.ps
----------------------------------------------------------------
then pdftops-test.ps contains misplaced letters.

Therefore the root cause is either in pdftops
or perhaps your test.pdf is somehow broken.

"pdfinfo test.pdf" shows
-----------------------------------------------------------------
Creator: Writer
Producer: LibreOffice 3.4
..
PDF version: 1.4
-----------------------------------------------------------------
The root cause could also be in LibreOffice 3.4 or in whatever
tool or library that is used by LibreOffice to produce PDFs.

/usr/bin/pdftops belongs to the poppler-tools RPM.

I re-assign it for now to the poppler-tools maintainer
to have a look whether or not the root cause is in pdftops.


When you print a PDF from the Adobe Reader, the Adobe Reader itself
converts the PDF to PS so that the Adobe Reader sends PS to CUPS.
Apparently the Adobe Reader PDF to PS conversion works best here
(it is known that often the Adobe Reader works best to print PDF)
to that at least for now you should use the Adobe Reader to print PDF
(regardless that the Adobe Reader is non-free software).

That it works with the Adobe Reader does not prove that your
test.pdf is strictly PDF version 1.4 compliant.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >