Mailinglist Archive: opensuse-bugs (4156 mails)

< Previous Next >
[Bug 660438] WxGTK is incompatible between OpenSUSE and Fedora

https://bugzilla.novell.com/show_bug.cgi?id=660438

https://bugzilla.novell.com/show_bug.cgi?id=660438#c19


--- Comment #19 from Stanislav Brabec <sbrabec@xxxxxxxx> 2012-01-09 21:42:50
CET ---
We already know, that --enable-stl really breaks ABI and causes crashes, that
--enable-unicode breaks ABI (but it changes library name), that
--enable-mediactrl slightly changes ABI and causes unresolved symbols. Every
such --enable-something change generated one or more bug reports in the past.
Do you want to repeat this experience?

In case of these compat options:

Enabling them enlarges size and indexes of wxTreeCtrl and wxHtmlCell on other
position than the end of the structure => Application compiled with compat
enabled will probably sometimes crash on memory corruption with libraries
compiled without compat enabled, even if the application does not use any
deprecated method. Reverse will not crash on memory corruption, but it may call
different methods than intended.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >