Mailinglist Archive: opensuse-bugs (4212 mails)

< Previous Next >
[Bug 724917] Can't start gnucash ("Unknown option name: maxdepth")

https://bugzilla.novell.com/show_bug.cgi?id=724917

https://bugzilla.novell.com/show_bug.cgi?id=724917#c35


Hemanth Guruva Reddy <meethemanth@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |meethemanth@xxxxxxxxx

--- Comment #35 from Hemanth Guruva Reddy <meethemanth@xxxxxxxxx> 2012-01-09
18:30:13 UTC ---
If this test helps with anything , With environment variable set

export GUILE_WARN_DEPRECATED="detailed"

and output of 'gnc-test-env' is that certain instructions used in gnucash is
deprecated.

#gnc-test-env
`(debug-enable 'debug)' is obsolete and has no effect.
Remove it from your code.


looks like the use of deprecated instruction is causing Gnucash to crash with:


;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/main.scm
failed:
;;; ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
Backtrace:
In ice-9/boot-9.scm:
170: 12 [catch #t #<catch-closure 8334e80> ...]
In unknown file:
?: 11 [catch-closure]
In ice-9/boot-9.scm:
2497: 10 [#<procedure 82f6430 at ice-9/boot-9.scm:2485:4 (name #:optional
autoload version #:key ensure)> # ...]
2763: 9 [try-module-autoload (gnucash main) #f]
2103: 8 [save-module-excursion #<procedure 83fa9c0 at ice-9/boot-9.scm:2764:17
()>]
2774: 7 [#<procedure 83fa9c0 at ice-9/boot-9.scm:2764:17 ()>]
In unknown file:
?: 6 [primitive-load-path "gnucash/main" #f]
In ice-9/eval.scm:
458: 5 [#<procedure 828e6c0 at ice-9/eval.scm:452:4 (exp)> #]
In ice-9/psyntax.scm:
1024: 4 [chi-top-sequence ((debug-set! maxdepth 100000)) () ...]
922: 3 [scan ((debug-set! maxdepth 100000)) () ...]
1015: 2 [scan ((#(syntax-object debug-options # ...) (# # #))) () ...]
In ice-9/boot-9.scm:
2854: 1 [debug-options (show-file-name #t stack ...)]
In unknown file:
?: 0 [debug-options-interface (show-file-name #t stack ...)]

ERROR: In procedure debug-options-interface:
ERROR: In procedure debug-options-interface: Unknown option name: maxdepth


PS: till then can guile's version and gnucash's version can be dropped to that
of last working config in 11.4

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >