Mailinglist Archive: opensuse-bugs (3547 mails)

< Previous Next >
[Bug 719205] New: tumbleweed: return from suspend -> no video
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 20 Sep 2011 14:20:11 +0000
  • Message-id: <bug-719205-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=719205

https://bugzilla.novell.com/show_bug.cgi?id=719205#c0


Summary: tumbleweed: return from suspend -> no video
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: jnelson-suse@xxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0.2) Gecko/20100101
Firefox/6.0.2

I have a ThinkPad T520 with Intel 3000 Video, an openSUSE 11.4 install running
tumbleweed and KDE 4.7.1.

By and large, it's a fabulous combination. However, I also use an external
monitor frequently, and instead of letting the laptop sit idle consuming power
for hours on end, I will typically suspend-to-RAM the laptop. This works very
well! However, upon return, the displays (both of them) remain dark. This
*only* happens when I am using the external monitor when I put the laptop to
sleep. The only fix is to control-alt-backspace a few times to kill X, at which
point things return to normal. Console does not work either.

On a related note, what might be the best way to hook a *user* process into
return-from-suspend. If I could hook into dbus somehow such that a user process
was run upon return-from-suspend, I could fix this with xrandr (in the short
term - this is not a real fix).



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages